Форум за електроника Форуми Форум за електроника

Форум за електроника
Български форум за електроника, ремонти, схеми, документация
 
 Въпроси/ОтговориВъпроси/Отговори   ТърсенеТърсене   ГрупиГрупи   Регистрирайте сеРегистрирайте се 
 ПрофилПрофил   Влезте, за да видите съобщенията сиВлезте, за да видите съобщенията си   ВходВход 

Service Manual Search :   Enhanced by: Jabse.com : българската търсачка
Програматор Willem-не програмира!?-Решено
Иди на страница 1, 2  Следваща
 
Създайте нова тема   Тази тема е заключена - не можеш да отговаряте или да променяте мнения    Форум за електроника Форуми -> Ремонти (на битова електроника)- Electronic equipment repairs
Предишната тема :: Следващата тема  
Автор Съобщение
evgevg
Опитен потребител
Опитен потребител


Регистриран на: 11 Юни 2005
Мнения: 1128
Местожителство: Казанлък

МнениеПуснато на: Чет Окт 15, 2009 23:18    Заглавие: Програматор Willem-не програмира!?-Решено Отговорете с цитат

Здравейте колеги.Скоро го купих ама още нищо не съм успял да програмирам.Пробвах с 37VF040-заради нея го купих,AE29F1008-15 и W27E512-все същото.Уж настройвам всичко по картинката и ключета и джъмпери а резултат няма.Къде греша?Качвам няколко снимки за нагледност ако видите грешка пишете.Не ме е яд за парите ама като не ми върши работа?Да отива в кофата ли?Незнам.







Последната промяна е направена от evgevg на Съб Окт 17, 2009 1:52; мнението е било променяно общо 1 път
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
prasse
Опитен потребител
Опитен потребител


Регистриран на: 26 Авг 2006
Мнения: 186
Местожителство: Велико Търново

МнениеПуснато на: Пет Окт 16, 2009 7:34    Заглавие: Отговорете с цитат

Пробвай с версия 0.97g...
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение
mteddy
Опитен потребител
Опитен потребител


Регистриран на: 31 Яну 2007
Мнения: 506
Местожителство: София

МнениеПуснато на: Пет Окт 16, 2009 8:46    Заглавие: Отговорете с цитат

Имаш един джъмпер повече(двата срещу W-то на Winbond). Пробвай с плъзгачите да вдигнеш tWP и tWC.
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
REPAIRMAN
Опитен потребител
Опитен потребител


Регистриран на: 05 Авг 2004
Мнения: 218

МнениеПуснато на: Пет Окт 16, 2009 15:57    Заглавие: Отговорете с цитат

Колега пробвай огледално разположение на джъмперите или нещо подобно.Наскор коментираха колеги подобен проблем-документацията за настройките позволяваха различно тълкуване.
Успех!
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
Ivan4o
Опитен потребител
Опитен потребител


Регистриран на: 31 Яну 2005
Мнения: 104
Местожителство: Дупница

МнениеПуснато на: Пет Окт 16, 2009 16:16    Заглавие: Отговорете с цитат

Доколкото виждам от снимките ти си на PCB3. Там според мен трябва да си ти е надписа Willem! Натисни за да го превключиш. И после захранването трябва да е според мен над това което е нужно за запис върху паметта, т.е 14V за сниманите от теб чипове.
_________________
Никога не е късно да станеш за резил...


Последната промяна е направена от Ivan4o на Пет Окт 16, 2009 16:23; мнението е било променяно общо 1 път
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
digital
Опитен потребител
Опитен потребител


Регистриран на: 08 Дек 2005
Мнения: 401
Местожителство: София

МнениеПуснато на: Пет Окт 16, 2009 16:18    Заглавие: Отговорете с цитат

Горе където пише PC83 го смени на Willem
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
ivpav
Опитен потребител
Опитен потребител


Регистриран на: 02 Ное 2006
Мнения: 539
Местожителство: Хасково

МнениеПуснато на: Пет Окт 16, 2009 16:56    Заглавие: Отговорете с цитат

Колеги не го бъркайте човека. Точно PCB3 му е версията и това си пише на софтуера. Моя е такъв и точно така си програмирам чиповете . По-скоро колегата да каже какво направи по тоя въпрос?
mteddy написа:
Имаш един джъмпер повече(двата срещу W-то на Winbond).

А също така да каже какво става като натисне бутона ID. Също така на: help-test hardware
evgevg Прочитането и индицирането, че всичко е OK на флаша не е индикатор,че програматора го е познал и прочел правино . Уилема за разлика от професионалните програматори не прави проверка за идентификация на чипа. Чак записа или проверката след изтриване е резонна. Освен това трий флаша задължително преди запис. Гледай да си с възможно най-къс кабел и се въоръжи с много търпение . Някой път много се глези тоя Уилем Confused
_________________
ИВАН ПАВЛОВ
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла Посетете сайта на потребителя
evgevg
Опитен потребител
Опитен потребител


Регистриран на: 11 Юни 2005
Мнения: 1128
Местожителство: Казанлък

МнениеПуснато на: Пет Окт 16, 2009 19:15    Заглавие: Отговорете с цитат

Здравейте колеги.Току що скъсих кабела от 1.5м на 40см-резултат няма.Чете но не трие и не записва.Пробвах версия 097g-няма резултат.Джъмпера го махнах и единия и другия, но пак неще.Разликата между PCB3 и Willem я виждам като огледален образ на ключетата и това не е.Мисля,че моя е PCB3.Бутона ID не е активен.При тест на хардуера изписва Hardware present.IVPAN кой са професионалните програматори?Ако знаеш линк?Имам компютър и с W98 ако пробвам там?Качвам и две снимки.

Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
ivpav
Опитен потребител
Опитен потребител


Регистриран на: 02 Ное 2006
Мнения: 539
Местожителство: Хасково

МнениеПуснато на: Пет Окт 16, 2009 20:08    Заглавие: Отговорете с цитат

evgevg Това е PCB3 и правилно си го задал в менюто. Имам такъв и си работи при мен с 1,20 метра кабел. Работя сега на XP с софтуер 0.97g а преди работех и на 98 без проблем . Компа в момента е PIII на 1266 MHz. Виж да не ти е двуядрен процесора, някои програми не работят коректно на тях.
Първо, направи проверка на буфера след четене . Виж дали ти дава някакъв смислен резултат при неизтрита памет или ти дава само 0xFF или 0x00 или 0x04 навсякъде . Тогава най-вероятно имаш грешка при четенето. Или зацапан цокъл или нещо друго. Да те предупредя при стари памети стояли на цокъл се появяват такива проблеми. Наскоро програмирах едни промове с джам . Докато не ги минах краката с ножа, все различни резултати давах.
Второ, пробвай с джъмпера за различни напрежеия на 5 волта . Въпреки, че това на мен ми е давало резултат само при някои флашове от биоси.
Вземи един флаш от биос 29f002 или 49f002 има ги много в различни разновидности по-стари дъна. Забелязал съм, че той най-лесно се пише и трие. Дано ти се получи . Провери си и в боса принтерния порт как е конфигуриран.
За професионалните програматори . Аз в много редки случаи вземам от един познат по-старата версия на ето този :
http://www.elnec.com/products/device-programmers/memprogl/
Като друг пример мога да ти дам един евтин модел на фирма за, която знам, че е много яка :
http://www.xeltek.com/product.php?productid=16225
В нета има много други прогрматори, които се продават. Но след като прекарах години в мъки с тази самоделка -Уилема, вече не смея да препоръчвам всяко нещо Smile . Все пак сега избора е голям, не е като едно време .
_________________
ИВАН ПАВЛОВ
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла Посетете сайта на потребителя
ELP
Опитен потребител
Опитен потребител


Регистриран на: 07 Яну 2004
Мнения: 6913
Местожителство: София

МнениеПуснато на: Пет Окт 16, 2009 20:34    Заглавие: Отговорете с цитат

Съжалявам ,но не мога да помогна много ,защото съм с версия PCB50 ,ако намеря подобни чипове -бих опитал все пак. Виж само адаптера с който го захранваш дали е читав .
Върнете се в началото
Вижте профила на потребителя Изпратете лично съобщение Изпрати мейла
Потърси "Програматор Willem-не програмира!?-Решено" в магазин за електроника Pulsator.bg : БЕЗПЛАТНА ДОСТАВКА над 90 лв.

Покажи мнения от преди:   
Потърси "Програматор Willem-не програмира!?-Решено" в Интернет



Създайте нова тема   Тази тема е заключена - не можеш да отговаряте или да променяте мнения    Форум за електроника Форуми -> Ремонти (на битова електроника)- Electronic equipment repairs Часовете са според зоната GMT + 2 Часа
Иди на страница 1, 2  Следваща
Страница 1 от 2

 
Към:  
Не Можете да пускате нови теми
Не Можете да отговаряте на темите
Не Можете да променяте съобщенията си
Не Можете да изтривате съобщенията си
Не Можете да гласувате в анкети